宝塔面板数据库显示: Parameter must be an array or an object that implements Countable

宝塔面板数据库显示: Parameter must be an array or an object that implements Countable

最近在使用数据库时出现错误:Warning in ./libraries/plugin_interface.lib.php#532count(): Parameter must be an array or an object that implements Countable原因是phpmyadmin版本不兼容当前使用的php版本导致的。应该你使用的是php7.2版本的,这个问题解决起来也比较容易,升级phpmyadmin的版本即可。

如果只有PHP5.2,请安装 phpmyadmin4.1。如果只有PHP5.5及以下版本,请安装phpmyadmin4.4。如果只有PHP7.x,请安装phpmyadmin4.7/4.8版本!用宝塔面板安装phpmyadmin 还是很方便的,但是突然宝塔的官网好像没人维护了,网站非常的乱。

具体的更新方法就比较简单了,先把原来的phpmyadmin卸载,然后重新安装相对应的版本即可,这里不再废话。

分享到 :

发表评论

登录... 后才能评论