使用WordPress的插件生成的xml地址打开报错:This page contains the following errors: error on line 2 at column 6: XML declaration allowed only at the start of the document Below is a rendering of the page up to the first error.

解决办法:打开“wordpress”根目录下的“wp-blog-header.php”文件,找到

$wp_did_header = true;

在后面添加以下代码:

ob_start();

然后再找到:

 wp();

并在后面添加以下代码:

ob_end_clean();

最后完整的“wp-blog-header.php”文件应该是这样的:

<?php
if ( ! isset( $wp_did_header ) ) {
	$wp_did_header = true;ob_start();
	// Load the WordPress library.
	require_once __DIR__ . '/wp-load.php';
	// Set up the WordPress query.
	wp(); ob_end_clean();
	// Load the theme template.
	require_once ABSPATH . WPINC . '/template-loader.php';
}

至此wordpress地图出错的问题就已经解决了。但是当wordpress有更新的时候它会自动更新上面代码中改动过的几处就又还原了,下面给出两种方法禁止wordpress自动更新的方法:

第一种方式:在主题“functions.php”文件中添加代码
 //关闭核心程序、主题、插件及翻译自动更新
add_filter( 'automatic_updater_disabled', '__return_true' );

或者根据自身需求选择以下代码:

//核心代码自动更新
add_filter( 'auto_update_core', '__return_false' );
//开发者版本自动更新
add_filter( 'allow_dev_auto_core_updates', '__return_false' );
//小版本自动更新
add_filter( 'allow_minor_auto_core_updates', '__return_false' );
//大版本自动更新
add_filter( 'allow_major_auto_core_updates', '__return_false' );
//插件自动更新
add_filter( 'auto_update_plugin', '__return_false' );
//主题自动更新
add_filter( 'auto_update_theme', '__return_false' );
//翻译文件自动更新,__return_true 为启用,__return_false 为禁用
add_filter( 'auto_update_translation', '__return_false' );
函数参数__return_true 为启用,__return_false 为禁用
第二种方式:在配置文件(wp-config.php)中关闭自动更新

在wordpress程序根目录找到文件,添加以下代码:

 //关闭核心程序、主题、插件及翻译自动更新
define( 'AUTOMATIC_UPDATER_DISABLED', true );

如果想开启WordPress自动更新,去掉对应的代码就可以了,只不过你还需要修改更新后的代码!

发表评论

后才能评论